[DISCUSS] end support for OpenJPA-1.x?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[DISCUSS] end support for OpenJPA-1.x?

Mark Struberg-3
hi folks!

I think the times of the 1.x rage of OpenJPA is over.
This is our JPA-1.0 branch (JavaEE5).
Wdyt about declaring it EOL and closing all the tickets for it?

Of course OpenJPA-2.x and 3.x will continue to be active!

LieGrue,
strub
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] end support for OpenJPA-1.x?

Romain Manni-Bucau
+1

Le lun. 7 janv. 2019 23:05, Mark Struberg <[hidden email]> a
écrit :

> hi folks!
>
> I think the times of the 1.x rage of OpenJPA is over.
> This is our JPA-1.0 branch (JavaEE5).
> Wdyt about declaring it EOL and closing all the tickets for it?
>
> Of course OpenJPA-2.x and 3.x will continue to be active!
>
> LieGrue,
> strub
>
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] end support for OpenJPA-1.x?

J Grassel
In reply to this post by Mark Struberg-3
The repository branches will remain (ie, not deleted) if they are declared
EOL?

On Mon, Jan 7, 2019 at 4:05 PM Mark Struberg <[hidden email]>
wrote:

> hi folks!
>
> I think the times of the 1.x rage of OpenJPA is over.
> This is our JPA-1.0 branch (JavaEE5).
> Wdyt about declaring it EOL and closing all the tickets for it?
>
> Of course OpenJPA-2.x and 3.x will continue to be active!
>
> LieGrue,
> strub
>
Reply | Threaded
Open this post in threaded view
|

Re: [DISCUSS] end support for OpenJPA-1.x?

Matthew Broadhead-2
In reply to this post by Mark Struberg-3
that sounds sensible.  although i only started using OpenJPA recently so
not sure how many are still depending on 1.x.  are any of the tickets
relevant to later versions and having high watch counts?

On 07/01/2019 23:05, Mark Struberg wrote:

> hi folks!
>
> I think the times of the 1.x rage of OpenJPA is over.
> This is our JPA-1.0 branch (JavaEE5).
> Wdyt about declaring it EOL and closing all the tickets for it?
>
> Of course OpenJPA-2.x and 3.x will continue to be active!
>
> LieGrue,
> strub