More test failures - JPA spec overwritten

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

More test failures - JPA spec overwritten

pveselov
Hello.

Trying to run more tests on 2.4.2. My first compilation was
successful, but now there is another phantom exception that I have no
clue how to resolve. Any help would be appreciated. I haven't made any
changes anywhere that should affect this...

I don't know where the JPA specification is set, or where, or what
file, is it coming from.

Exception stack trace : https://pastebin.com/qPuPxjRP

--
With best of best regards
Pawel S. Veselov
Reply | Threaded
Open this post in threaded view
|

Re: More test failures - JPA spec overwritten

pveselov
On Sun, Apr 8, 2018 at 5:22 PM, Pawel Veselov <[hidden email]> wrote:
> Trying to run more tests on 2.4.2. My first compilation was
> successful, but now there is another phantom exception that I have no
> clue how to resolve. Any help would be appreciated. I haven't made any
> changes anywhere that should affect this...
>
> I don't know where the JPA specification is set, or where, or what
> file, is it coming from.

OK, this was just me panicking. That trace was an expected failure.
The only problem that I don't quite understand that I have left during
running tests is: https://pastebin.com/aPciDKR8

The enhancer version of the enhanced classes is 2, but the enhancer is
1674154, which matches the SVN revision of the enhancer, and I believe
that's what it should be. I don't know where it gets the 2 from.
Reply | Threaded
Open this post in threaded view
|

Re: More test failures - JPA spec overwritten

Matthew Broadhead
the latest version isn't 2.4.2 is it?  i thought that was an old
version.  i just checked out revision 1828727.  how do you know which
revision is 2.4.2?
i checked this http://openjpa.apache.org/building.html and didn't see
anything


On 09/04/2018 02:16, Pawel Veselov wrote:

> On Sun, Apr 8, 2018 at 5:22 PM, Pawel Veselov <[hidden email]> wrote:
>> Trying to run more tests on 2.4.2. My first compilation was
>> successful, but now there is another phantom exception that I have no
>> clue how to resolve. Any help would be appreciated. I haven't made any
>> changes anywhere that should affect this...
>>
>> I don't know where the JPA specification is set, or where, or what
>> file, is it coming from.
> OK, this was just me panicking. That trace was an expected failure.
> The only problem that I don't quite understand that I have left during
> running tests is: https://pastebin.com/aPciDKR8
>
> The enhancer version of the enhanced classes is 2, but the enhancer is
> 1674154, which matches the SVN revision of the enhancer, and I believe
> that's what it should be. I don't know where it gets the 2 from.

Reply | Threaded
Open this post in threaded view
|

Re: More test failures - JPA spec overwritten

pveselov
On Mon, Apr 9, 2018 at 5:01 PM, Matthew Broadhead
<[hidden email]> wrote:
>> The enhancer version of the enhanced classes is 2, but the enhancer is
>> 1674154, which matches the SVN revision of the enhancer, and I believe
>> that's what it should be. I don't know where it gets the 2 from.
> the latest version isn't 2.4.2 is it?  i thought that was an old version.  i
> just checked out revision 1828727.  how do you know which revision is 2.4.2?
> i checked this http://openjpa.apache.org/building.html and didn't see
> anything

It's 2.4.2 because I checked out
http://svn.apache.org/repos/asf/openjpa/tags/2.4.2. 2.4.2 is at
1828187
The revision for the enhancer version is taken from the SVN revision
of the enhancer, not the workspace.
Enhancer is at openjpa-kernel/src/main/java/org/apache/openjpa/enhance/PCEnhancer.java,
and its latest revision, from 2.4.2 PoV is 1674154
Reply | Threaded
Open this post in threaded view
|

Re: More test failures - JPA spec overwritten

Matthew Broadhead
i ran
svn checkout http://svn.apache.org/repos/asf/openjpa/tags/2.4.2/ 
openjpa-2.4.2
cd openjpa-2.4.2
mvn install
and it built first time without errors

On 09/04/2018 23:43, Pawel Veselov wrote:

> On Mon, Apr 9, 2018 at 5:01 PM, Matthew Broadhead
> <[hidden email]> wrote:
>>> The enhancer version of the enhanced classes is 2, but the enhancer is
>>> 1674154, which matches the SVN revision of the enhancer, and I believe
>>> that's what it should be. I don't know where it gets the 2 from.
>> the latest version isn't 2.4.2 is it?  i thought that was an old version.  i
>> just checked out revision 1828727.  how do you know which revision is 2.4.2?
>> i checked this http://openjpa.apache.org/building.html and didn't see
>> anything
> It's 2.4.2 because I checked out
> http://svn.apache.org/repos/asf/openjpa/tags/2.4.2. 2.4.2 is at
> 1828187
> The revision for the enhancer version is taken from the SVN revision
> of the enhancer, not the workspace.
> Enhancer is at openjpa-kernel/src/main/java/org/apache/openjpa/enhance/PCEnhancer.java,
> and its latest revision, from 2.4.2 PoV is 1674154